Skip to content
logo Knowledgebase

Error: "I/O Error in the file [directory][dat file]"

Created on  | Last modified on 

Summary

An I/O error occurs "Reading or writing to the file [...]" in Sage 50 Accounting. "I/O Error in variable length part of record" in one of the company .DAT files.

Description

I/O error in one of the following files: 

Address.dat AdvData.dat AdvHist.dat Aflocat.dat Alarm.dat Alert.dat Apiaccss.dat
Atmntbdl.dat Attchmnt.dat Audittr.dat Avgdtpay.dat Bankrec.dat Bddetail.dat Bomhist.dat
Budget.dat Budgetar.dat Cashflow.dat Cfacct.dat Cftrans.dat Chart.dat Chartar.dat
ChgOrder.dat CODetail.dat Company.dat Connco.dat Contacts.dat Cosess.dat Cost.dat
Customer.dat Defprfld.dat EarnSumm.dat Employee.dat EmpPayinf.dat Empprfld.dat Esprfld.dat
EsWage.dat Event.dat Eventlog.dat Eventcls.dat Forecast.dat Foredtl.dat General.dat
GLCoat.dat Grpdata.dat Invchain.dat Invcomp.dat Invcost.dat Jrnlcls.dat Jrnlhdr.dat
Jrnlrow.dat Jrnlsno.dat Lineitem.dat NotAdMsg.dat NotCdVal.dat Notifica.dat NotMsg.dat
NotRecip.dat NotRules.dat Olacct.dat Oltrans.dat Paymethd.dat PDSIDMap.dat Pepusage.dat
Periodar.dat Permiss.dat Phase.dat Project.dat QtyDisc.dat RaiseHst.dat Recon.dat
Recpttag.dat Recurex.dat Report.dat Review.dat Roles.dat Rptdata.dat Rptfilts.dat
Rstydef.dat Rstyle.dat Statcode.dat Stathist.dat Statnote.dat Storetrx.dat Stxhdr.dat
Stxrow.dat Syspref.dat Taxauth.dat Vendor.dat Taxcode.dat Taxtable.dat Template.dat
Ticket.dat Unitmeas.dat Userpref.dat Userrole.dat Vendins.dat Vendor.dat Worktkt.dat

Cause

  • Incorrect file settings
  • Incorrect permissions on a shared folder
  • Damaged file
  • Bad sector on hard drive
  • Company data folder not in data path

Resolution

 NOTE: If this error occurs during a data conversion: 

  1. Reinstall the prior version and restore the pre-conversion backup.
  2. Run Data Verification on the company.
  3. Reinstall the new version and convert the company again.

 NOTE: In the instance that the error occurs on just one workstation, first try rebooting the workstation. If the error was preceded by a File System Error 3110, 3111, 3006, etc., refer to Error: "File System Error 3110". 

If the company is a shared Remote Data Access company, stop sharing the company immediately and see if the error continues.

  • If the error still occurs after stopping sharing the company, continue through the troubleshooting steps below
  • If the error stops when the company isn’t shared, go to Using Remote Data Access below

If your file isn’t in the list above

I/O error in a file that can be safely deleted without corrupting your data

I/O error in file [filename].DAT that can be reindexed

If you're able to open the company, you can run Integrity check to reindex the file:

NOTE:

If you can't open the company, you can run a Repair Company instead, which reindexes all the files.

  1.  Select Help, Support Utilities.
  2. Select Integrity Check.
  3. Select Backup.
  4. Give your backup a name, choose where you would like to save the backup, and then select Save.
  5. In the Integrity Check window, select Reindex Files.
  6. From the Reindex File List, select the file mentioned in the error, and then select OK.
  • If you receive an error message that the file couldn’t be reindexed, browse out to the file location, right-click the file and select Properties. If the Read-only checkbox is checked, uncheck it, and then try again to reindex the file.
  • If the file wasn’t read only, or if it was and the second attempt to reindex the file fails, you’ll need to restore a backup made before getting the error.

I/O error in file [filename].DAT that can’t be reindexed in Integrity Check

  1. You can attempt to run the Repair Company utility if you have an I/O error in a file that is not on the reindex file list.
    • If you're on the 2024.0 version, you’ll need to install the 2024.0.1 patch update before you can run Repair Company
  2. If you receive an error message that the file couldn’t be reindexed, browse out to the file location, right-click the file and select Properties. If the Read-only checkbox is checked, uncheck it, and then run the Repair Company again.
  3. If the file wasn’t read only, or if it was and the second attempt fails, you’ll need to restore a backup made before getting the error.

Check file permissions

See Verify my data file permissions are correctly set.

Company data folder not in data path

  1. If your company data folder isn’t in the data path, especially on a removable USB drive, an I/O error can result.
  2. Browse to the location of the folder that contains the file listed, and copy this entire data folder. For example, if the error message listed the file as F:\Peachw\acmecorp\EventLog.DAT, browse to F:\Peachw and copy the acmecorp folder.
  3. Browse to your data path.
  4. Paste the folder into the data path.
  5. Verify that you can open your company.
  6. Check hard drive for errors
  7. Consult your local computer technician or Microsoft support for assistance with checking the hard drive for errors.
  8. Using Remote Data Access
  9. Verify that your Internet upload and download speeds are sufficient to use Remote Data Access.
  • For broadband Internet, the FCC specifies 25 Mbps download/3 Mbps upload as the minimum, although in System Requirements: Sage 50—U.S. Edition 2024 specifies 25 Mbps download / 10 Mbps upload as the minimum recommended Internet speed for best performance
  • You can test your Internet speed at speedtest.net. If your Internet speed doesn't meet either of the above benchmarks, contact your Internet Service Provider to see if your Internet speed can be increased
  • If you’re using a WiFi connection, it’s recommended to use a wired Ethernet connection, as this is more stable

Need more help?

Chat now

 

 

Related Solutions

How to restore a backup
How to locate company directories
How can I determine what files are used for what purpose in the program files and data path directory?