Summary
Description
I/O error in one of the following files:
Address.dat | AdvData.dat | AdvHist.dat | Aflocat.dat | Alarm.dat | Alert.dat | Apiaccss.dat |
Atmntbdl.dat | Attchmnt.dat | Audittr.dat | Avgdtpay.dat | Bankrec.dat | Bddetail.dat | Bomhist.dat |
Budget.dat | Budgetar.dat | Cashflow.dat | Cfacct.dat | Cftrans.dat | Chart.dat | Chartar.dat |
ChgOrder.dat | CODetail.dat | Company.dat | Connco.dat | Contacts.dat | Cosess.dat | Cost.dat |
Customer.dat | Defprfld.dat | EarnSumm.dat | Employee.dat | EmpPayinf.dat | Empprfld.dat | Esprfld.dat |
EsWage.dat | Event.dat | Eventlog.dat | Eventcls.dat | Forecast.dat | Foredtl.dat | General.dat |
GLCoat.dat | Grpdata.dat | Invchain.dat | Invcomp.dat | Invcost.dat | Jrnlcls.dat | Jrnlhdr.dat |
Jrnlrow.dat | Jrnlsno.dat | Lineitem.dat | NotAdMsg.dat | NotCdVal.dat | Notifica.dat | NotMsg.dat |
NotRecip.dat | NotRules.dat | Olacct.dat | Oltrans.dat | Paymethd.dat | PDSIDMap.dat | Pepusage.dat |
Periodar.dat | Permiss.dat | Phase.dat | Project.dat | QtyDisc.dat | RaiseHst.dat | Recon.dat |
Recpttag.dat | Recurex.dat | Report.dat | Review.dat | Roles.dat | Rptdata.dat | Rptfilts.dat |
Rstydef.dat | Rstyle.dat | Statcode.dat | Stathist.dat | Statnote.dat | Storetrx.dat | Stxhdr.dat |
Stxrow.dat | Syspref.dat | Taxauth.dat | Vendor.dat | Taxcode.dat | Taxtable.dat | Template.dat |
Ticket.dat | Unitmeas.dat | Userpref.dat | Userrole.dat | Vendins.dat | Vendor.dat | Worktkt.dat |
Cause
- Incorrect file settings
- Incorrect permissions on a shared folder
- Damaged file
- Bad sector on hard drive
- Company data folder not in data path
Resolution
NOTE: If this error occurs during a data conversion:
- Reinstall the prior version and restore the pre-conversion backup.
- Run Data Verification on the company.
- Reinstall the new version and convert the company again.
NOTE: In the instance that the error occurs on just one workstation, first try rebooting the workstation. If the error was preceded by a File System Error 3110, 3111, 3006, etc., refer to Error: "File System Error 3110".
If the company is shared on Remote Data Access, stop sharing the company immediately and see if the error continues.
- If the error still occurs after stopping sharing the company, continue through the troubleshooting steps below
- If the error stops when the company isn’t shared, go to Using Remote Data Access below
If your file isn’t in the list above
- If the file mentioned in the error message isn’t in the list above, see I/O Error in non-data files
- Otherwise, see What files can be reindexed? to determine if the file can be reindexed or safely deleted
I/O error in a file that can be safely deleted without corrupting your data
- See What files can be reindexed? for information on which files can be safely deleted without corrupting your database
- If you’re receiving any kind of I/O error in one of these files, and you’re willing to live with the loss of data that the file holds, browse out to your company data folder and delete the file
- If the file can’t be safely deleted, see Verify my data file permissions are correctly set
I/O error in file [filename].DAT that can be reindexed
- Select Help, Support Utilities.
- Select Integrity Check.
- Select Backup
- Give your backup a name, choose where you would like to save the backup, and then select Save.
- In the Integrity Check window, select Reindex Files.
- From the Reindex File List, select the file mentioned in the error, and then select OK.
- If you receive an error message that the file couldn’t be reindexed, browse out to the file location, right-click the file and select Properties. If the Read-only check box is checked, uncheck it, and then try again to reindex the file.
- If the file wasn’t read only, or if it was and the second attempt to reindex the file fails, you’ll need to restore a backup made before getting the error.
I/O error in file [filename].DAT that can’t be reindexed in Integrity Check
- You can attempt to run the Repair Company utility if you have an I/O error in a file that is not on the reindex file list.
- If you are on the 2024.0 version, you’ll need to install the 2024.0.1 patch update before you can run Repair Company
- If you receive an error message that the file couldn’t be reindexed, browse out to the file location, right-click the file and select Properties. If the Read-only check box is checked, uncheck it, and then run the Repair Company again.
- If the file wasn’t read only, or if it was and the second attempt fails, you’ll need to restore a backup made before getting the error.
Check file permissions
See Verify my data file permissions are correctly set.
Company data folder not in data path
If your company data folder isn’t located in the data path, especially on a removable USB drive, an I/O error can result.
- Browse to the location of the folder which contains the file listed and copy this entire data folder. For example, if the error message listed the file as F:\Peachw\acmecorp\EventLog.DAT, you would browse to F:\Peachw and copy the acmecorp folder.
- Browse to your data path.
- Paste the folder into the data path.
- Verify that you can open your company.
Check hard drive for errors
Consult your local computer technician or Microsoft support for assistance with checking the hard drive for errors.
Using Remote Data Access
Verify that your Internet upload and download speeds are sufficient to use Remote Data Access.
- For broadband Internet, the FCC specifies 25 Mbps download / 3 Mbps upload as the minimum, although in System Requirements: Sage 50—U.S. Edition 2024 specifies 25 Mbps download / 10 Mbps upload as the minimum recommended Internet speed for best performance
- You can test your Internet speed at speedtest.net. If your Internet speed doesn't meet either of the above benchmarks, you may need to contact your Internet Service Provider to see if your Internet speed can be increased
- If you’re using a WiFi connection, it’s recommended to use a wired Ethernet connection, as this is more stable
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