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Error: "I/O Error in the file [directory][dat file]"

Created on  | Last modified on 

Summary

I/O error occurs "Reading or writing to the file [...]" in Sage 50 Accounting. "I/O Error in variable length part of record" in one of the company .DAT files.

Description

I/O error in one of the following files: 

Address.datAdvData.datAdvHist.datAflocat.datAlarm.datAlert.datApiaccss.dat
Atmntbdl.datAttchmnt.datAudittr.datAvgdtpay.datBankrec.datBddetail.datBomhist.dat
Budget.datBudgetar.datCashflow.datCfacct.datCftrans.datChart.datChartar.dat
ChgOrder.datCODetail.datCompany.datConnco.datContacts.datCosess.datCost.dat
Customer.datDefprfld.datEarnSumm.datEmployee.datEmpPayinf.datEmpprfld.datEsprfld.dat
EsWage.datEvent.datEventlog.datEventcls.datForecast.datForedtl.datGeneral.dat
GLCoat.datGrpdata.datInvchain.datInvcomp.datInvcost.datJrnlcls.datJrnlhdr.dat
Jrnlrow.datJrnlsno.datLineitem.datNotAdMsg.datNotCdVal.datNotifica.datNotMsg.dat
NotRecip.datNotRules.datOlacct.datOltrans.datPaymethd.datPDSIDMap.datPepusage.dat
Periodar.datPermiss.datPhase.datProject.datQtyDisc.datRaiseHst.datRecon.dat
Recpttag.datRecurex.datReport.datReview.datRoles.datRptdata.datRptfilts.dat
Rstydef.datRstyle.datStatcode.datStathist.datStatnote.datStoretrx.datStxhdr.dat
Stxrow.datSyspref.datTaxauth.datVendor.datTaxcode.datTaxtable.datTemplate.dat
Ticket.datUnitmeas.datUserpref.datUserrole.datVendins.datVendor.datWorktkt.dat

Cause

  • Incorrect file settings
  • Incorrect permissions on a shared folder
  • Damaged file
  • Bad sector on hard drive
  • Company data folder not in data path

Resolution

 NOTE: If this error occurs during a data conversion: 

  1. Reinstall the prior version and restore the pre-conversion backup.
  2. Run Data Verification on the company.
  3. Reinstall the new version and convert the company again.

 NOTE: In the instance that the error occurs on just one workstation, first try rebooting the workstation. If the error was preceded by a File System Error 3110, 3111, 3006, etc., refer to Error: "File System Error 3110". 

If the company is shared on Remote Data Access, stop sharing the company immediately and see if the error continues.

  • If the error still occurs after stopping sharing the company, continue through the troubleshooting steps below
  • If the error stops when the company isn’t shared, go to Using Remote Data Access below

 

If your file isn’t in the list above

I/O error in a file that can be safely deleted without corrupting your data

I/O error in file [filename].DAT that can be reindexed

  1. Select Help, Support Utilities.
  2. Select Integrity Check.
  3. Select Backup
  4. Give your backup a name, choose where you would like to save the backup, and then select Save.
  5. In the Integrity Check window, select Reindex Files.
  6. From the Reindex File List, select the file mentioned in the error, and then select OK.
  • If you receive an error message that the file couldn’t be reindexed, browse out to the file location, right-click the file and select Properties. If the Read-only check box is checked, uncheck it, and then try again to reindex the file.
  • If the file wasn’t read only, or if it was and the second attempt to reindex the file fails, you’ll need to restore a backup made before getting the error.

I/O error in file [filename].DAT that can’t be reindexed in Integrity Check

  1. You can attempt to run the Repair Company utility if you have an I/O error in a file that is not on the reindex file list.
    • If you are on the 2024.0 version, you’ll need to install the 2024.0.1 patch update before you can run Repair Company
  2. If you receive an error message that the file couldn’t be reindexed, browse out to the file location, right-click the file and select Properties. If the Read-only check box is checked, uncheck it, and then run the Repair Company again.
  3. If the file wasn’t read only, or if it was and the second attempt fails, you’ll need to restore a backup made before getting the error.

Check file permissions

See Verify my data file permissions are correctly set.

Company data folder not in data path

If your company data folder isn’t located in the data path, especially on a removable USB drive, an I/O error can result.

  1. Browse to the location of the folder which contains the file listed and copy this entire data folder. For example, if the error message listed the file as F:\Peachw\acmecorp\EventLog.DAT, you would browse to F:\Peachw and copy the acmecorp folder.
  2. Browse to your data path.
  3. Paste the folder into the data path.
  4. Verify that you can open your company.

Check hard drive for errors

Consult your local computer technician or Microsoft support for assistance with checking the hard drive for errors.

Using Remote Data Access

Verify that your Internet upload and download speeds are sufficient to use Remote Data Access.

  • For broadband Internet, the FCC specifies 25 Mbps download / 3 Mbps upload as the minimum, although in System Requirements: Sage 50—U.S. Edition 2024 specifies 25 Mbps download / 10 Mbps upload as the minimum recommended Internet speed for best performance
  • You can test your Internet speed at speedtest.net. If your Internet speed doesn't meet either of the above benchmarks, you may need to contact your Internet Service Provider to see if your Internet speed can be increased
  • If you’re using a WiFi connection, it’s recommended to use a wired Ethernet connection, as this is more stable

 

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