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Error: "Sage 50 cannot connect to its database, Actian Zen on computer [server]."

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Summary

How to resolve this error, which is preventing Sage 50 Accounting from opening.

Description

Error: "Sage 50 cannot connect to its database on computer [server]. Make sure the computer is logged in or that the database service is running. Also make sure the firewall is set to allow Sage 50 and Pervasive to pass through. Click Help for more information. Click Retry to attempt to connect again."

Cause

  • Actian service stopped on the server
  • Unable to ping the server
  • Network location/profile set to Public instead of Private on workstation and/or Server
  • Firewall blocking program
  • Incorrect server name in ~PVSW~.LOC file
  • Using a distributed file system (DFS) for mapped drive
  • Damaged Windows Management Instrumentation (WMI)
  • Incorrect data path on workstation
  • Server and workstations on different versions
  • More than one NIC enabled
  • Using IPv6 instead of IPv4
  • The Windows machine hosting the Sage data has reached the maximum number of concurrent Server Message Block (SMB) sessions (20) allowed on Windows 11 client operating systems

Resolution

 NOTE: If you’re receiving the error, "Sage 50 cannot connect to its database on 169" or 192, etc., where the error shows the computer name as the first three digits of an IP address, see Error: "Sage 50 cannot connect to its database on 169" 

Restart Actian Zen

  1. Stop and then start the Actian database engine on the server.
  2. Following the same steps, top and then start the Actian database engine on the workstations.

Incorrect data path

Follow How to verify that the data path is correct on a server or stand-alone computer.

Network Profile set to Public on workstation and/or server

We recommend that you don't set your network location/network profile to Public.

  1. Locate your network connection. This is either Wi-Fi or Ethernet in the service tray in the bottom-right corner of your Taskbar.
  2. Right-click your network connection and select Open Network and Internet Settings.
    • If the network status is Private network or Domain Network, then it’s set correctly
    • If the network status is Public network, then change it by clicking the Properties button
  3. Under Network change the radio button from Public to Private.
  4. Select the back arrow at the top left twice and close the Settings window.
  5. Test connectivity.
  6. If you still have the error proceed to the next section. 

Configure firewall

Configure the firewall to allow the files for Sage 50 through.

Incorrect or blank server name in ~PVSW~.LOC file

  1. Browse to the data path.
  2. Open the ~PVSW~.LOC file in Notepad.
  3. Replace the incorrect server name with the correct server name.

Network communication problem

  1. At the workstation, ping the server by name.
  2. Follow the same steps at the server to ping the workstation by name.

If you receive a Request timed out message on either step above or if you have a latency of greater than 10ms: Contact your IT network administrator.

Mapped the drive using IP Address

In release 2021.1 and higher, you can use UNC (Universal Naming Convention) paths for the data path instead of mapped drives. For example, \\server01\Peachtree\Company.

  1. Open File Explorer and browse to C:\ProgramData\Sage\Peachtree.
  2. Open the configuration file for your version (2023: Peachtree300.ini).
  3. Change the DATAPATH= line to the correct company data UNC path; for example, \\server01\Peachtree\Company. If you have other workstations running Sage, you can copy the UNC path from the DATAPATH line of their configuration file.

Damaged Actian database on server

  1. Completely remove and reinstall Actian.
  2. Open the program and verify that the issue no longer occurs.

Using DFS for mapped drive

Sage 50 Accounting can't use a DFS share. Disconnect the drive and map the drive using the standard UNC path. For more detailed information, see Can the program run on a Distributed File System (DFS).

Server and workstations on different versions

Ensure that the server and the workstations are on the same version and update. If not, then apply the latest update to the server and all workstations. You can view the updates by going to Services, Check for Updates in the software.

Damaged WMI

  1. Press the Windows key + R.
  2. In the Run box, type eventvwr.
  3. Select OK.
  4. Select Windows Logs, and then Application.
  5. If you see error messages referencing WMI, you’ll need to consult your IT professional or Microsoft Support.

Using IPv6 instead of IPv4

Server Message Block (SMB) session limit in Windows 11

When it reaches the SMB session limit, Windows refuses new network file‑coordination connections. Sage interprets this operating-system-level failure as a generic “Cannot connect to data path” error, even though the data path itself is valid. This is a Windows operating system limitation, not a Sage configuration issue.

Verify the SMB session limit:

NOTE:

  • SMB sessions aren't the same as users
  • A single user or a single machine can consume multiple SMB sessions
  • Idle sessions still count towards the limit
  1. On the Sage host machine or server, go to Start and Computer Management.
  2. Go to System Tools, Shared Folders, and Sessions.
  3. Count the number of session entries. Each row represents one active SMB session.

If 20 active sessions are present, the system has reached the SMB session limit. Additional connections will fail and can display misleading data path errors.

Rebooting the machine will temporarily restore access. If the problem keeps recurring, the resolution is to migrate the Sage data to a Windows Server operating system, which doesn't have the 20-session SMB limitation.

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