Error: "A protection device or license is required" (Pervasive)
Description
Note: as of 9/30/2018, replacement keys/dongles are no longer available.
Note: Sage will continue to offer limited Sage Estimating Pervasive support through 2018. This means customer support will be able to help with common component questions but not be able to fix issues within the Pervasive environment.
Cause
There can be several different causes of this particular error message.
Resolution
[BCB:3:Network warning:ECB]
[BCB:5:Third-party support:ECB]

Alway check to see what type or types of licenses they using. i.e. Stand alone or License Manager.

For issues that only apply to License Manager you will see (LM) in the title of the article in the Related resources below. The other links apply to a Stand alone set up or both Licesne Manager and Stand alone licenses.

Please see links below for possible solutions to this problem. The list below in Related Resources might be able to help determine the issue.

Error: "A protection device or license is required" (Remote Desktop Connection) (Pervasive)
Error: "A protection device or license is required" (LM) (LSFORCEHOST environment variable) (Pervasive)
Error: "A protection device or license is required" (Computer name was changed or computer was imaged) (Pervasive)
Error: "The system cannot retrieve the servers, there is no response to the broadcast" (License Manager - Pervasive)
Error: "A protection device or license is required" (LM) (Router or Switch not forwarding LM network packets) (Pervasive)
Error: "A protection device or license is required" (LM) (A firewall is blocking the connection) (Pervasive)
Error: "A protection device or license is required" (LM) server lost its licenses) (Pervasive)
Error: "A protection device or license is required" (LM) license code is missing) (Pervasive)
Error: "A protection device or license is required to use Timberline applications" after installing Windows 10 version 1803. (Pervasive)

Steps to duplicate
Related Solutions